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Overview of BrailleMath 
 
 BrailleMath is a software package that helps teachers teach mathematics to 
blind students. This package is developed using image processing and special language 
translation techniques. The prime use of this software is to help sighted teachers teach 
mathematics to blind students. In just a few easy steps, the teacher can convert a Braille 
page typed by a blind student into “Print Form,” readable by sighted people, thereby 
saving a lot of time for the teacher. 
   
 
 
Salient Features of the product:  

 Takes as input, a scanned copy of the Braille sheet hand typed on a Perkins 
Brailler and outputs a PDF file. 

 BrailleMath can handle slanted typed lines as well as irregularly typed lines. 
 Documents can contain Nemeth Code and Literary Braille. Nemeth Code 

expressions are automatically separated from contracted Braille text. 
 BrailleMath also handles spatial math:  

o Determinants  
o Matrices  
o Grade school,  

 Addition  
 Subtraction  
 Multiplication  
 Long Division, etc.  

 Nemeth Code Syntax errors made by the student are detected and confined to 
the smallest possible area and rest of the document translated correctly. 

 User has full control at every step and can change/modify the document in any 
of the intermediate steps. 

 User has the choice of either doing step by step conversion or doing direct 
conversion to pdf. 
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1 Hardware requirements 
Memory: 128MB. (256MB recommended) 
CPU: Pentium III or faster 
Scanner:   300DPI resolution (recommended) or more 
Printer: Inkjet or Laser (recommended) 

2 Software requirements 
 Operating System: Windows XP (All variants) or higher 
 Adobe Acrobat Reader (User needs to install this) 
 MiKTeX (MiKTeX installer is part of BrailleMath package. Needs to be installed).  
 Aspell (Aspell installer is part of BrailleMath package. Needs to be installed). 
 Aspell Dictionary (Dictionary installer is part of BrailleMath package. Needs to be 

installed). 
 Braille Fonts. (Need to copy Braille Fonts from Installer folder\Braille_Font to 

“C:\Windows\Fonts” on your machine). 

3 Installing BrailleMath 
 Download the BrailleMath software from 

http://www.interoperate.biz/braillemath_purchase.php 
 Install ‘Aspell’ from the folder. 
 Install “Aspell Dictionary” from the folder.  
 Install ‘Miktex’ from the folder. 
 Copy Braille Fonts from <Installer folder>\Braille_Font to “C:\Windows\Fonts” on 

your machine. 
 Add “C:\Program Files\Aspell\bin” to your windows path  
 Now run the setup for BrailleMath; follow the instructions of the installer. 
 The installer will help you navigate throughout your installation process. 
 When installation is finished you can see BrailleMath shortcut on your desktop.  
 The folder “C:\Program Files\Interoperate.biz\BrailleMath” will be created 

where all the executables and supporting resources are copied. 

4 Using BrailleMath 

4.1 Scanning the Braille Page 

 Scan the back side of the Braille page to avoid ink marks, if any, on the front side 
of the Braille page. Scanning should be done at 300 DPI resolution. (A sample 
image with staple marks and ink marks is shown in APPENDIX figure – A1) 
Front side of the image can also be scanned but then ink marks or other marks, if 
any, should be manually removed from the image (step 4.2). 



 Save the scanned Braille page on your computer in JPEG Format. 
 Proceed to Next Step. (4.2). 
 In case of a clean Braille sheet, you can move on to step 4.3. 

4.2 Edit the Braille Page using MS Paint 

 Open MS Paint. 
 Open the JPEG image that you saved in previous step. (4.1) 
 Flip the image horizontally/vertically depending on how the image is scanned. 
 Delete staple marks & ink marks on the image, if any, using MS Paint eraser. 
 To delete, you can select any area on the image that does not contain blobs and 

copy-paste it over the area from where marks are to be deleted. 
 Save the image. 
 Proceed to Next Step. (4.3) 

4.3 Loading the Braille Page 

 Open BrailleMath. You will see a blank window as shown in figure 1. 
 

 
Figure – 1 

 
 Click on File > Open. You will see a dialog box as shown in figure 2. 
 



 
Figure – 2 

 
 

 Select “BrailleImage Files (*.jpg)” from the “Files of type” drop down box. 
 Select the JPEG file saved in step 4.2.  
 Click Open. 
 The Braille image loads into the window. The window will appear as shown in figure-3. 
 



 
      Figure -3 

4.4 Converting into ASCII 

 
 At this point there are two options: direct conversion or step by step conversion. 
 DIRECT CONVERSION: To perform direct conversion, click on the double  

green arrow shortcut button on the tool bar (highlighted in Figure-3) or select  
menu “Image > Convert to pdf”. BrailleMath will carry out all the intermediate  
steps without your intervention and will display the final pdf file. Intermediate files  
that are generated will also be displayed. Be patient, as performing all the  
intermediate steps may take a few minutes.  
 
Note: If a black window labeled “C:\WINDOWS\system32\cmd.exe” appears that 
seems to be paused for a response from you, then press “Enter” repeatedly until the  
window disappears.  

 STEP BY STEP CONVERSION: In step by step conversion, select menu “Image > Convert 
to ASCII” or use the shortcut button on the toolbar as shown in Figure 3. 

 A warning message will be displayed. Click OK. 
 If the system is uncertain about a certain line, sometimes it may ask you if the 
blob         (or Braille dot) on a particular line belongs to left column or right column.  
 Verify the same with the original hardcopy Braille page and select either  
 “LEFT_COLUMN” or “RIGHT_COLUMN” 
 Press OK. (The dialog box is shown in figure 4 below.) 
 



 
Figure – 4 

 
 By following the above steps, optical Braille recognition is performed by BrailleMath,          and 

the Braille characters converted into corresponding ASCII characters.  
 ASCII file is opened in the document view as shown in Figure 5 
 For further translation  proceed to next step (4.5) 
 Otherwise, to avoid going through intermediate steps manually, select the option to        

convert input JPG file directly to PDF print format by selecting from the menu: “Image > 
Convert To PDF” or using the shortcut button on the toolbar. 

 BrailleMath will internally perform all the intermediate stages and display the final output in 
PDF format. 

4.5 Separating Math 

 The window with the ASCII file will look like as shown in figure 5 below. 
 At this point the user can edit the ASCII file either directly in the screen shown in Figure 5, 

or through a Blob Editor (see later). This editing may be needed to fix minor errors since 
optical Braille recognition is not always perfect. 

 To convert further, there are two options given to user. These two options are  
1. Stepwise Conversion 

A.  Identification of Nemeth Math and contracted Braille, followed by 
B.  Translating delimited ASCII file to print math and text (PDF). 

2. Do complete conversion in one step. Here, user need not bother about identification of   
math. Identification is done in a manner transparent to the user. 

 For complete conversion in one step, select ‘Nemeth Translation > Convert ASCII to   PDF’ 
BrailleMath internally does the math separation, generates the Latex file, converts       it into 
PDF print format and displays it in the “acrobat reader”. User can proceed to          next step 
(4.7). 

 
 



 
Figure – 5 

 Step-wise conversion may have to be performed because automatic separation of Math    
and text may not be perfect due to mistakes made by a student while typing Braille or        
due to errors in the optical Braille recognition step. The user can fix Math identification 
errors by doing step wise conversion as follows: 

 Select “Nemeth Translation  Separate Math” from the Menu or select corresponding 
button on toolbar as shown in figure-5. BrailleMath will enclose all Math expressions   
within ;; and ;’ tags. These tags can be made more visible by selecting “Nemeth    
Translation > Show Math Tag” which will display ;; as <MATH> and ;’ as </MATH>. 

 These Math Tags resemble HTML Tags. User can manually remove the <MATH> and 
</MATH> tags if the system wrongly identifies some text as Math. Also, user can insert    the 
<MATH> and </MATH> tags around expressions that are not identified as Math. 

 Double click the left mouse button to insert <MATH> and double click the right mouse 
button to insert </MATH> after placing the cursor at the desired place. 

 Once the desired changes are made to the Nemeth File, click on the “save” icon on the 
toolbar to save the file. 

 Proceed to next step. (4.6) 

4.6 Converting to LaTeX 

 Click on the “Nemeth Translation > Convert separated ASCII to Latex” from the 
Menu  or corresponding button on toolbar as shown in figure-5 

 Once the conversion is completed, a dialog box will popup asking if you would 
like to view the Latex file. 

 Click “Yes” to view the latex file; “No” if you do not wish to view the Latex file. 



 After your selection, the latex document will be converted to a PDF document 
and is saved in the same folder as your Braille Image. 

 Click ‘Yes” in the dialog box that appears, to view the PDF output. 
 Proceed to Next Step. (4.7). 

4.7 Printing PDF Document 

 Now that you have viewed the PDF document, you may wish to print the 
document by clicking “File > Print” from the Menu. 

 

4.8 Other Features of BrailleMath 

 

 
Figure - 6 

 
1. Edit Image :  This feature opens jpg image in MS Paint and allows user to edit the 

image . To use this feature, select “Image > Edit image” or select corresponding 
button on the toolbar as shown in the figure - 6. Using MS Paint eraser user can 
edit a JPG image. User can also darken the dots, if they were scanned 
improperly. After editing the image, REMEMBER TO SAVE THE FILE. 

 



 
      Figure – 7 
 
2. Show Blob Image : This feature shows the blob image to a user. This is very 

helpful feature in scenarios where input image is not very bright and BrailleMath 
has difficulty in recognizing the dots.  To use this feature , select “Image > Show 
blob image” from menu or select corresponding button on the toolbar as shown 
in the figure 6. Blob image will appear as shown in figure-8. A dot that is not 
surrounded by a rectangle has not been recognized by BrailleMath. At this point 
you can edit the JPG image of the Braille Sheet to darken that particular dot 
using MS Paint, or you can use the Blob Editor, described next. The Blob Image 
displayed (figure 8) itself cannot be directly edited. 

 
     Figure - 8 



3. Blob Editor: Once the JPG image file has been converted to ASCII (step 4.4), the 
user may view it in Braille, compare it to the original hard copy Braille and, edit it 
using the Blob Editor that has been provided in BrailleMath. This editing may be 
needed due to possible errors in the optical Braille recognition step. Frequently, 
the shadow of a Braille dot may be too faint to be recognized, causing the 
characters to be interpreted wrongly (A faint dot that has been ignored, will 
appear as a dot without a rectangle enclosing it when the “Image > Show Blob 
Image” option is used as explained in the previous section (see Figure 8)).  

 The blob editor displays the individual Braille characters as a series of 3x2 
dots which can be turned on and off simply by clicking the mouse. The 
teacher performing the back-translation can load the ASCII Braille file into 
the blob editor and then compare it to the original Braille hard copy 
document, and fix any mistakes observed. To invoke the Blob Editor, 
select “Nemeth Translation > Invoke Blob Editor” (Figure 9). 

 The user can turn individual Braille dots on and off by simply clicking on 
them. 

 Once the ASCII file has been fixed, it must be saved, and the saved file 
opened in the BrailleMath system for translation to pdf.  

 

 
Figure 9 

 
 The Blob Editor with an ASCII file loaded is shown below (Figure 10). Every 

raised dot recognized in the hard copy Braille sheet appears as a black dot. 
 



 
Figure 10 

 
 

4. Translating Contracted Braille: This feature allows user to translate contracted 
Braille phrases. As shown in the following figure (figure -11) user can input 
contracted Braille in the text box named “Enter Literary Braille Text”. After 
pressing the “Translate” button, corresponding latex expression along with error 
message, if any, is displayed. 

 

      Figure - 11 



 
5. Translating  Nemeth Expression : This feature allows users to evaluate Nemeth 

Math expressions. As shown in the following figure (figure - 12) user can input 
Nemeth Expression in the text box named “Enter a Nemeth Math Expression”. 
After pressing the “Translate” button, corresponding latex expression along with 
error message, if any, is displayed. 

 

 
      Figure – 12 
 

 
6. Set environment : It allows to set the following environment parameters: 
 
A. Image threshold : 

 

 
Figure – 13 

 



As shown in figure 13, we can set four environment variables associated with image 
thresholds. 
 

1. Binarized Threshold : Gray scale value used for binarizing pixels. 
 
2. Blob Threshold :  Minimum number of continuous pixels for a blob to be 

considered as a black blob. 
 

3. Min Filter Threshold:  Minimum number of pixels in a blob for it to be considered 
a Braille dot. 

 
4. Max Filter Threshold:   Maximum number of pixels in a blob for it to be 

considered a Braille dot.  
 
 
B. Image File name: It sets the output files names for the image processor. Dialog box 
that allows these file names to be set is shown in Figure 14. 

 
Figure – 14 

 
File names that can be changed are:  

1. Blobs file name  
2. Image filter file name 
3. Mark blobs  file name 
4. Warning file name 



5. Line Dimension file name 
6. Mark CHAR file name 
7. Mark DOTS file name 
8. ASCII file name 
9. BLOBS image file name 
10. Dots and text file name 

 
 
C. Nemeth FileName: This option is used to set the file names for  
      1. Error report file name 
      2. Log file name. 
 
It also asks whether to generate PDF file or not. The dialog box used for setting these 
options is shown in Figure 15. 
 

 
Figure – 15 

 



 

5 APPENDIX 

5.1 Sample image showing staple marks and ink marks on a Braille page 

 
Figure – A1 



6 TroubleShooting  
 

 Scenario 1: Nemeth file is opened and some changes are made to it and 
then the translator is called. But changes are not reflected in the output file. 
Solution: It is very important to note that every time you make any change in 
any of the open files, the file should be explicitly saved before using it as an 
input in any of the phases of the translation. 

 
 Scenario 2 : While converting to PDF a black screen comes  as shown in 

figure – 12 and nothing happens after this 
 

 
      Figure - 12 

Solution:  You will encounter this if there are some errors in the input 
document that cannot be translated correctly. The Latex system that 
converts Latex to Pdf may throw an error in such a situation. Latex will show 
the error it has encountered via the black screen. The black screen shows 
the line number in the latex file where the error occurred. You can either 
manually go and edit the latex file or just hit “Enter.” If you hit “Enter” Latex 
will ignore the error and will resume producing the output. 



 
 Scenario 3 : Following error message pop up 
 

 
     Figure - 13 
  Solution: Make sure that adobe acrobat reader is not open. If it is open then   
close it and rerun the translation. 

7 Frequently Asked Questions 
 

1. Do I need to install Aspell on my machine before using BrailleMath? 
A.  You need to install Aspell on your machine to run BrailleMath correctly. 

After you install Aspell, you need to add “C:\Program Files\Aspell\bin” to 
windows PATH. 

  
2. Do I need to install acrobat reader? 
A. Yes, you need to have adobe acrobat reader installed on your machine. 
 
3. What if the final output looks strange? 
A. In this scenario, perform the following checks:  

1. Check the blob image to find out if there is any problem in image 
recognition. If you see some problem, you can manually edit either the 
JPG image or the ASCII file using the Blob Editor. 

2. If it looks like that image recognition is correct, check the Nemeth Math 
delimited ASCII file. If it looks like that some part is not separated 
correctly you can add/remove <MATH> & </MATH> delimiters manually. 

3. Check the error file and log file to find any specific reason of errors. 
4. After doing these checks you can re-translate to Print Math format. 
5.  It may be possible that original Braille document has typing mistakes 

and/or occurrences of incorrect Nemeth code. 
       

4. Sometimes nothing happens for many seconds.  
A. Be Patient!!!  Different modules such as image processing and math recognition 

do extensive checking / analysis so in some cases it may take up to few minutes 
to get the output. 

 
5.    Still have questions: Send email to info@interoperate.biz 

 


